My Oracle Support Banner

"java version 1.6.0_21 is not supported. The minimum version required is 1.6.0_24" When using JDK 1.6.0_211 in JDeveloper 11.1.1.7 (Doc ID 2884966.1)

Last updated on JULY 25, 2022

Applies to:

Oracle JDeveloper - Version 11.1.1.7.0 and later
Information in this document applies to any platform.

Symptoms

On : 11.1.1.7.0 version, JDeveloper Core (Apps, Projects, Customizations, etc.)

When attempting to switch to JDK 1.6.0_221 in JDeveloper 11.1.1.7 to be able to use TLS1.2 for HTTPS URL connections, the following error occurs.



The issue can be reproduced at will with the following steps:
1. Change the JDK in JDeveloper 11.1.1.7 from 1.6.0_24 into 1.6.0_211
2. Set the new java home in jdev.conf file to point to jdk 1.6.0_211.
3. JDeveloper does not start and the following error appears.

    "java version 1.6.0_21 is not supported. The minimum version required is 1.6.0_24"




Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.