My Oracle Support Banner

"java.lang.UnsupportedClassVersionError" Error Thrown When Starting Coherence 14.1.1.2206.3 With Java 8 (Doc ID 2936342.1)

Last updated on MARCH 25, 2024

Applies to:

Oracle Coherence - Version 14.1.1.2206.1 and later
Information in this document applies to any platform.

Goal

Qn1:After applying the Coherence FP 14.1.1.2206.3 patch, getting below error when starting the Coherence Server with jdk1.8:


Coherence 14.1.1.2206.3 start up is working fine with java 11. Is Coherence FP compatible with JDK 8 ?
 
Qn2:Is Coherence 14.1.1.2206.3 running with JDK 11 supported on RHEL6, RHEL 7 & RHEL 8?
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.