My Oracle Support Banner

Primary Note for JRE Security Warnings and Forms Jar Files Expiration (Doc ID 2939490.1)

Last updated on AUGUST 30, 2023

Applies to:

Oracle Forms for OCI - Version 12.2.1.4.0 and later
Oracle Forms - Version 12.2.1.0.0 and later
Information in this document applies to any platform.

Purpose

 The purpose of this note is to address all known causes and solutions for JRE Security Warning and Forms Jar Files Expiration in Forms 12c.

Scope

In cases the errors were caused by bugs that have been fixed, the fixes are included in the latest bundle patches of your version.

Oracle strongly recommends to use the latest supported version and to apply the latest QPR on top of it:

Doc ID 2834458.2 Oracle Forms Quarterly Patch Release (QPR) information.

Listed here are Security errors caused by current defects or incorrect configuration

Details

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Purpose
Scope
Details
 JRE Security Warning - UNKNOWN Publisher Blocked in Future Releases
 Missing Application-Library-Allowable-Codebase Manifest
 Java Was Blocked because It Is out of Date
 “Do you want to run this application?", "Application Blocked by Java Security","Running this application may be a security risk"
 Forms Java Certificate Error Application Blocked By Java Security
 Java has discovered application components that could indicate a security concern
 Forms Jar File Certificate Expiration and Timestamp Functionality
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.