Upgrading an Imported Repository Fails with ORA-1917, ORA-6512, ORA-2124 (Doc ID 297254.1)

Last updated on OCTOBER 27, 2016

Applies to:

Oracle Repository - Version: 6.5 to 9.0 - Release: Designer 6i to Designer 6i
Information in this document applies to any platform.
Repository Administration Utility

***Checked for relevance on 30-Nov-2011***

Symptoms

Upgrading an imported repository fails with the following errors:

  ORA-01917: user or role 'CKR_<repository owner>' does not exist
  ORA-06512: at line 66
  RME-02124: Failed to execute SQL statement:

The sequence of events leading up to the errors are:

  1. Install a new version of Designer.
  2. An old version of Designer exists on another machine.
  3. An old version of the repository exists.
  4. Create a new database.
  5. Follow the steps in the Repository Installation Guide to create a new repository owner with the
    same name as the repository owner of the old repository.
  6. Export the repository with the old version of the Repository Administration Utility (RAU).
  7. Import the repository with the old version of the RAU.
  8. Invoke the new RAU and connect to the imported repository.
  9. Click the Upgrade button.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms