Troubleshooting Problems with Report Server and SSO / Portal Integration

(Doc ID 298174.1)

Last updated on JULY 05, 2016

Applies to:

Oracle Reports Developer - Version 9.0.2.0 to 10.1.2.3 [Release 9i to 10gr2]
Information in this document applies to any platform.
Checked for relevance on "02-Feb-2015"


Goal

PURPOSE

To provide some troubleshooting hints/ tips and solutions to problems / errors that can occur when running reports using SSO ,portal and report server.

SCOPE & APPLICATION

The article is specific to:

Oracle 9iAS Rel 2 Reports Services (Reports 9i (9.0.2))
Oracle Application Server 10g R1 (9.0.4) Reports Services (Reports 10g (9.0.4)) 
Oracle Application Server 10g R2 (10.1.2) Reports Services (Reports 10g Release 2 (10.1.2))

Target Audience: Support Engineers, Consultants, System Administrators, DBAs and Developers

OVERVIEW of using security options

Following are the ways in which the reports server can be secured:

1. Using SSO server

To use SSO server for authenticating the user following changes needs to be done-

A) Enable the security tag in report server configuration file by uncommenting it.

B) Uncomment the SINGLESIGNON=YES parameter in rwservlet.properties file.

2. Using Report Server

 By enabling the security tag in report server configuration file the security for reprot server is enabled.

Even if SSO is not used ,the report server authenticates the user by itself .

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms