Run Time Warnings Occur When Converting Apache Web Server from non-SSL to SSL (Doc ID 314748.1)

Last updated on MARCH 08, 2017

Applies to:

COREid Access - Version: 7.0.4 and later   [Release: and later ]
Information in this document applies to any platform.
Checked for relevance on 12-Apr-2010

Symptoms

When I convert your Apache servers from non-SSL to SSL, everything compiles OK, with no problems or errors. But when I start the Apache server in SSL mode, I get some run time warnings.    These are shown below.

$./apachectl startssl [Wed Jan 15 14:09:12 2003] [warn] Loaded DSO /d/NP60/webpass/identity/oblix/apps/obmodule_loader/bin/libobmodule_loader.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI) [Wed Jan 15 14:09:12 2003] [warn] Loaded DSO /d/NP60/webpass/access/oblix/apps/module_loader/bin/obmodule_loader.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI) Apache/1.3.27 mod_ssl/2.8.12 (Pass Phrase Dialog) Some of your private key files are encrypted for security reasons. In order to read them you have to provide us with the pass phrases. Server myserver.mycompany.com:443 (RSA) Enter pass phrase: Ok: Pass Phrase Dialog successful. ./apachectl startssl: httpd started $

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms