My Oracle Support Banner

Mid-Tier Mod_osso Not Working After Entring Usernaem/Pw Oracle Sso Failure (Doc ID 377779.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle9iAS Single Sign-On - Version: 10.1.2.0.2
This problem can occur on any platform.

Symptoms

Tested mod_osso on a Mid-tier server per  <> How to verify mod_osso is working, which confirmed an issue with mod_osso

-Steps to reproduce the issue:
1. In a new browser session enter the following URL:
http://servername.domain/private

This brings up the SSO login page

2. Enter the username/password, which returns the following error:

Oracle SSO Failure - Unable to process request
Either the requested URL was not specified in terms of a fully-qualified host
name or OHS single sign-on is incorrectly configured.
Please notify your administrator


-From same browser session, if you enter another SSO partner application URL on a different server (SSO Admin, OIDDAS), you are not challenged for authentication.

-The same mod_osso test on the infrastructure was successful

-Tested a static page and it did not work unless we added a slash to the end of the url /


Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
  Symptoms
  Cause
  Solution

This document is being delivered to you via Oracle Support's Rapid Visibility (RaV) process, and therefore has not been subject to an independent technical review.

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.