My Oracle Support Banner

Setting Up JDBC Connections to Teradata V2R5 and V2R6 for ODI 10g (Doc ID 424225.1)

Last updated on DECEMBER 20, 2019

Applies to:

Oracle Data Integrator - Version 3.2.03.01 to 10.1.3.9.99
Information in this document applies to any platform.

Goal

  1. What does the following error mean? Is it possible to avoid it?
    java.sql.SQLException: [NCR][Teradata JDBC Driver]:addBatch not supported
  2. How should NCR Teradata JDBC drivers v3.1.0.101 and v3.2.0.0 be set up?
          
  3. When using Teradata Utilities (TDU) 7.00 to connect to Teradata V2R6, a message is signaled indicating that the connection mode is deprecated. What is the problem here?

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution
 The addBatch error is frequently encountered with Teradata V2R5 and JDBC driver v3.0
 JDBC driver v3.1.0.101 works with Teradata V2R4.1.x, V2R5.0, and V2R5.1 
 JDBC driver v3.2.0.0 works with Teradata V2R5.0, V2R5.1, and V2R6.0
 In order to connect to Teradata V2R6, the Teradata Utilities (TDU) 8.00 are required

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.