OID 10g Replication Server Process (oidrepld) Fails To Start Unless Debug Is Enabled (Doc ID 433029.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle Internet Directory - Version 9.0.4 to 10.1.2 [Release 10gR1 to 10gR2]
Information in this document applies to any platform.

Symptoms

Starting Oracle Internet Directory (OID) 10g Replication Server (oidrepld) with debug on is successful, for example:

oidctl server=oidrepld connect=<servicename> instance=1 flags='-p 389 -h oidserver -d 67108863' start


Starting oidrepld without debug, for example using either single or double quotes in the flags does not make a difference:

oidctl server=oidrepld connect=<servicename> instance=1 flags="-p 389 -h oidserver" start
oidctl server=oidrepld connect=<servicename> instance=1 flags='-p 389 -h oidserver' start 


If then retrying with debug on again, it fails:

oidctl server=oidrepld connect=<servicename> instance=1 flags='-p 389 -h oidserver -d 67108863' start
*** Instance Number already in use. ***

*** Please try a different Instance number. ***

But oidrepld is not started / still down.


The $ORACLE_HOME/ldap/log/oidrepld00.log shows error:

...<SNIP>...
oidrepld: Release 9.0.4.2.0 - Production on Fri May 4 16:28:15 2007

(c) Copyright 2001 Oracle Corporation. All rights reserved.

2007/05/04:16:28:15 * Starting OIDREPLD against oidserver":389...
2007/05/04:16:28:15 * gslrcfcReadReplConfig::Can't connect to oidserver":389.
2007/05/04:16:28:15 * Failed to read replication configuration information.
...<SNIP>....

(Notice a doublequote after the hostname in the log entry above.)

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms