My Oracle Support Banner

Oracle Application Server 10g Release 3 (10.1.3) Installation Requirements for Microsoft Windows Vista / 2008 / 2008R2 (Doc ID 444112.1)

Last updated on MARCH 12, 2021

Applies to:

Oracle Fusion Middleware - Version 10.1.3.0.0 to 10.1.3.5.0 [Release AS10gR3]
Microsoft Windows (32-bit)
Microsoft Windows x64 (64-bit)
Oracle Application Server 10g Enterprise Edition - Version: 10.1.3.0.0 to 10.1.3.5.0
Checked for relevance on 05-Jan-2015


Details

Oracle Application Server 10g Release 3 (10.1.3) Installation Requirements for Microsoft Windows

 

This document provides supplemental instructions and requirements for installing Oracle Application Server 10g Release 3 (10.1.3) on Microsift Windows platforms to be aligned with certification provided from the following location:

Oracle SOA and WebCenter (10.1.3.1 and 10.1.3.2) Certification Information
[http://www.oracle.com/technetwork/middleware/ias/downloads/oracle-soa-certification-r3-10-131499.xls]

Oracle has tested this combination and provides this document to list additional requirements, complementing the Windows Installation Guide and Release Notes. The above Certification Guide has all certifications for Windows platforms. This document outlines the extra steps required to install and be certified on Windows Vista and Windows 2008.

 

Notes:
  • Note that Windows 7 is not certified unless it is in the above spreadsheet referencing this document for updates. At this time, there are no plans to certify 10.1.3 on Windows 7. Please consider the Oracle Fusion Middleware 11g releases.

  • There will be no further certifications beyond what is in this document for the 10.1.3 release. It is has passed Premier Support and the direction is to begin using 11g or 12c on the newer platforms.

  • New installations of Oracle Application Server 10g Release 3 (10.1.3.0.0) have been deprecated. It is recommended to install SOA Suite 10g 10.1.3.1, WebCenter 10g 10.1.3.2, or Oracle Application Server Companion CD 10.1.3.1, depending on your needs and certifications. See their respective Installation Guides for installation options.

    <Note 433061.1> How to Obtain Application Server Media, Patchsets, and Patches

 

Actions

The included Windows platform versions have been released after the Oracle Application Server 10g Release 3 (10.1.3), and thus must undergo a post-release certification process. If installing on the included Windows platforms before reading this document, you will get a similar error from the Installer:

Starting Oracle Universal Installer...
Checking installer requirements...
Checking operating system version: must be 5.0, 5.1 or 5.2 . Actual 6.0 Failed <<<<
or
Checking operating system version: must be 5.0, 5.1 or 5.2 . Actual 6.1 Failed <<<<

In order to correct this, review the following installation requirements and known issues while installing Oracle Application Server 10g Release 3 (10.1.3) on the included Microsoft Windows platforms. If you get the above message and your Windows platform version is not included here or within the Certification Guide, it is not certified.

Windows Vista


1. Requirements Before Starting Installer on Windows Vista

In order to start the installer on Windows Vista, apply the appropriate patch for your product:

Product Patch
10.1.3.0.0 <Patch:6153290>
10.1.3.1.0 SOA <Patch:6153302>
10.1.3.1.0/10.1.3.5.0 Companion CD <Patch:6153382>
10.1.3.1.0 BPEL Standalone <Patch:6153333>
10.1.3.1.0 ESB Standalone <Patch:6153340>
10.1.3.1.0 OWSM Standalone <Patch:6153348>
10.1.3.2.0 WebCenter <Patch:6153307>
10.1.3.2 WebCenter Companion CD <Patch:6153395>
10.1.3.1/10.1.3.2 Companion CD ASG Install <Patch:6153404>
10.1.3.1/10.1.3.2 Companion CD Failsafe Install <Patch:6153410>

Note:
The patches listed above apply to both 32 and 64 bit versions of Windows Vista.

2. Required Minimum Level After Installation on Windows Vista

Oracle Application Server 10g Patch Set 3 (10.1.3.3) or higher is required to be fully certified on Microsoft Vista. The 10.1.3.3 Release Notes provides solutions to known issues on Windows Vista, which are also included in the Known Issues section of this document, as they would apply to all subsequent 10.1.3.x Patchsets. <Patch:9216697> is 10.1.3.5 and the suggested Patch Set to apply. The 10.1.3.5 Patch Set should be applied even if you have installed the Companion CD version 10.1.3.5.0, in order to update required components. You may obtain the latest Patchset information within the following document:

<Note 397022.1> Oracle Application Server 10g Release 3 (10.1.3) Support Status and Alerts

The latest Patch Sets apply one-off patches which may not be built for Windows Vista. To allow these to apply without error, set OPATCH_PLATFORM_ID equal to "912" in your environment before starting the Patch Set installer. This is set in the Control Panel, System Properties, Advanced tab, and click "Environment Variables". After setting, ensure it is seen in the environment when executing "set" from a dos command prompt.

After the Patch Set is applied, it is recommended to remove this and set on an as-needed basis, only when applying one-off patches you have confirmed applicable to your Windows Vista environment. For example, issue the following command from the dos command prompt you will also be using when using the OPatch utility:

> set OPATCH_PLATFORM_ID=912
> setup.exe -ignoreSysPreReqs

Windows 7



Windows 7 (32 or 64 bit) is not a certified platform for Oracle Application Server 10g Release 3 (10.1.3) releases, unless the following Certification Guide is updated and referencing this document for further instructions:

Oracle SOA and WebCenter (10.1.3.1 and 10.1.3.2) Certification Information
[http://www.oracle.com/technetwork/middleware/ias/downloads/oracle-soa-certification-r3-10-131499.xls]

At this time, there are no plans to certify on Windows 7. Any updates will ONLY be within the above document first. For testing purposes only, the steps for Windows 2008 (32 bit) or Windows 2008 R2 (64 bit) have worked in limited testing environments. Please note that it is NOT supportable if you have any issues on Windows 7. You will be required to install and reproduce any issue on a certified Windows platform.

 

Windows 2008


1. Requirements Before Starting Installer on Windows 2008

Please note this this is not Windows 2008 R2. If you have Windows 2008 R2, see next section. In order to start the installer on Windows 2008 R1, apply the appropriate patch for your product: 

Product Patch
10.1.3.1.0 SOA <Patch:6712338>
10.1.3.1.0/10.1.3.5.0 Companion CD <Patch:7129052>
10.1.3.2.0 WebCenter <Patch:6971010>
10.1.3.1/10.1.3.2 Companion CD ASG Install <Patch:7129469>
10.1.3.1/10.1.3.2 Companion CD Failsafe Install <Patch:7191497>

Note:
The patches listed above apply to both 32 and 64 bit versions of Windows 2008.

 

2. Required Minimum Level After Installation on Windows 2008

Please note this this is not Windows 2008 R2. If you have Windows 2008 R2, see next section. Oracle Application Server 10g Patch Set 3 (10.1.3.4) or higher is required to be fully certified on Microsoft Windows 2008 R1. The 10.1.3.4 Release Notes provides solutions to known issues on Windows 2008, which are also included in the Known Issues section of this document, as they would apply to all subsequent 10.1.3.x Patchsets. <Patch:9216697> is 10.1.3.5 and the suggested Patch Set to apply. The 10.1.3.5 Patch Set should be applied even if you have installed the Companion CD version 10.1.3.5.0, in order to update required components. You may obtain the latest Patch Set information within the following document:

<Note 397022.1> Oracle Application Server 10g Release 3 (10.1.3) Support Status and Alerts

The latest Patch Sets apply one-off patches which may not be built for Windows 2008. To allow these to apply without error, set OPATCH_PLATFORM_ID equal to "912" in your environment before starting the Patch Set installer. This is set in the Control Panel, System Properties, Advanced tab, and click "Environment Variables". After setting, ensure it is seen in the environment when executing "set" from a dos command prompt.

After the Patch Set is applied, it is recommended to remove this and set on an as-needed basis, only when applying one-off patches you have confirmed applicable to your Windows 2008 environment. For example, issue the following command from the dos command prompt you will also be using when using the OPatch utility:

> set OPATCH_PLATFORM_ID=912
> setup.exe -ignoreSysPreReqs

 

 

Windows 2008 R2


1. Requirements Before Starting Installer on Windows 2008 R2

 

2. Required Minimum Level After Installation on Windows 2008 R2