My Oracle Support Banner

MultiSort causes subsequent search results pages to be blank (Doc ID 447147.1)

Last updated on SEPTEMBER 26, 2019

Applies to:

Oracle WebCenter Content - Version 7.5.1 to 7.5.1 [Release Stellent]
Information in this document applies to any platform.
Product: Content Server
Version: 7.5.1

Symptoms

I search on some metadata fields and receive multiple pages of results with 20 items on a page. When I click to go to page 2, the page is empty and states "Search Results Found 0 items matching the query." Looking at the IsJava output for page 2, the results are coming back but they're just not being displayed.

If I disable the MultiSort component (Content ID oly_045298, Version=2005_08_04), then the search results display correctly on multiple pages.

In Configuration Manager, the value for the option list that I'm doing a search on is "0530 Monthly Reports - Internal". It looks like that isn't an ordinary dash, but rather, an endash. If I do a search picking that value from the option list, I get page 1 of the results and then a blank page 2. If I search on that field but truncate the value to "0530 Monthly Reports", then page 2 shows the results correctly.

Can this be resolved so I can keep this value in the option list with the endash, and also keep the MultiSort component enabled?

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.