iStudio Cannot Connect To Repository After Application Server Upgrade From 10.1.2.0 To 10.1.2.2 (Doc ID 558643.1)

Last updated on SEPTEMBER 30, 2010

Applies to:

Oracle Applications InterConnect Tool Kit - Version: 10.1.2.2 and later   [Release: AS10gR2 and later ]
Information in this document applies to any platform.
***Checked for relevance on 30-Sep-2010***

Symptoms

After upgrading the middle-tier Application Server housing the InterConnect repository from 10.1.2.0.0 to 10.1.2.2, iStudio cannot connect to the repository and writes the following error to the iStudioLog.txt file:

java.io.InvalidClassException: oracle.aob.repository.aobRepositoryCartridge.
RepDataType; local class incompatible: stream classdesc serialVersionUID =
2069464746145719463, local class serialVersionUID = 7825321989848841051
at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:463)
at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1521)
at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1435)
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1626)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1274)
at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1845)
at java.io.ObjectInputStream.defaultReadObject(ObjectInputStream.java:452)
...


Steps To Reproduce

  • upgrade the application server hosting InterConnect from 10.1.2.0.0 to 10.1.2.2
  • attempt to connect to the repository using iStudio 10.1.2.0.0

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms