My Oracle Support Banner

ESB Runtime Restart Fails to Load EM Webservice Test Page and/or Does not Load the SOAP Endpoint URI Test Page from the ESB Control for the Service (Doc ID 727547.1)

Last updated on MAY 25, 2019

Applies to:

Oracle Enterprise Service Bus - Version 10.1.3.1 to 10.1.3.5
Information in this document applies to any platform.

Symptoms

Sporadically after restart of the BPEL/ESB server the ESB services do not load into the ESB Runtime.  This manifestsitself by not being able to see the ESB services in the Enterprise Manager Web Services Test Page and/or not being able to see the test page when selecting the SOAP Endpoint URI from the ESB Control "Definition" tab of an ESB service.

Though the services may not be seen as mentioned above, the services may actually function without any problems.

This has been seen in the following two circumstances:

(1)  A clustered type of environment when BPEL and ESB Runtimes are in one OC4J container and the ESB Designtime is in the same Oracle Home as BPEL and ESB Runtime, but in its own separate OC4J container.

(2)  There are many ESB services deployed to the server ~< 100+ where this may only be seen for a certain seemingly random number of services, where other services are loaded without issue.

 

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.