OPatch failed because of Inventory problem (Doc ID 736658.1)

Last updated on JANUARY 09, 2017

Applies to:

Portal - Version 10.1.2.0.0 to 10.1.4.2 [Release 10gR2]
Information in this document applies to any platform.

Symptoms

Unable to install a Portal repository patch.

Command:

[myPortal]$ cd $ORACLE_HOME/OPatch
[myPortal]$ ./opatch apply /home/myPatches/7131775 -pre "-s portal -p Pa55w0rd -c myPortal.server.com:1521:iasdb.myPortal.server.com"


Output:

Creating log file "/opt/u01/app/oracle/product/ias1012/.patch_storage/7131775/Apply_7131775_09-09-2008_13-32-53.log"
Starting OPatch Apply session at 09-09-2008_13-32-53.
Command arguments parsed by OPatch are: apply  -silent -pre ???
OPatch version is: 1.0.0.0.58

The contents of the file: /etc/oraInst.loc
inventory_loc=/opt/u01/app/oracle/product/oraInventory
inst_group=
Performing RAC pre-req. check...
Accessing inventory ... (retry 10 times, delay 30 seconds each time)

System Command: /opt/u01/app/oracle/product/ias1012/jre/1.4.2/bin/java
-Doracle.installer.invPtrLoc=/etc/oraInst.loc -Dopatch.retry=10 -Dopatch.delay=30  -classpath
"/opt/u01/app/oracle/product/ias1012/oui/jlib/OraInstaller.jar:/opt/u01/app/oracle/product/ias1012/o
ui/jlib/srvm.jar:/opt/u01/app/oracle/product/ias1012/OPatch/jlib/opatch.jar:/opt/u01/app/oracle/prod
uct/ias1012/oui/jlib/xmlparserv2.jar:/opt/u01/app/oracle/product/ias1012/oui/jlib/share.jar:/opt/u01
/app/oracle/product/ias1012/jlib/srvm.jar" opatch/O2O "/opt/u01/app/oracle/product/ias1012"
"/opt/u01/app/oracle/product/ias1012/oui" opatch.pl 1.0.0.0.58

Result:
OPATCH_JAVA_ERROR=OUI Version: 10.2.0.4.0
OPatch requires OUI 10.1 or earlier.
OPATCH_JAVA_ERROR=OUI Version: 10.2.0.4.0
OPATCH_JAVA_ERROR=OUI Version: 10.2.0.4.0
OPatch requires OUI 10.1 or earlier.
Cannot set up OUI inventory session.

ERROR: OPatch failed because of Inventory problem.



Changes

Oracle Universal Installer 10.2.0.4 installed in the Portal middle-tier. Encountered issue reported in Note 736652.1.

In an attempt to resolve the version compatibility problem, OPatch 10.2.0.4 was replaced with OPatch 1.0.0.0.xx (Patch 6880880), 1.0.0.0.58 at the time of occurrence of this problem.

Output of the following command will provide the version of Oracle Universal Installer currently installed in the Oracle Home:

$ORACLE_HOME/OPatch/opatch lsinventory -detail

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms