OAM Workflow with Custom Plugin Fails: Unable to open the shared library .... version 'GCC_4.2.0' not found (Doc ID 743070.1)

Last updated on MARCH 08, 2017

Applies to:

COREid Identity - Version: 10.1.4 and later   [Release: 10g and later ]
Linux x86
Red Hat Advanced Server
Linux x86-64
Checked for relevance on 11-Apr-2010

Symptoms

After implementing a custom workflow plugin in Identity Server installed on Linux platform the following error is
displayed in the browser when the workflow is executed:

"Unable to open the shared library /opt/oam/identity/oblix/unsupported/ppp/ppp_dll/libppp_dll.so - ../../../lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)"


The same plugin may run successfully on another apparently identical Linux-based server.

The Identity Server oblog shows the following errors:

2008/10/02@16:37:34.880293      3390    327700  INIT    ERROR   0x000003B6  ../obport.cpp:814       "Could not read file" shlibname^/opt/oam/identity/oblix/unsupported/ppp/ppp_dll/libppp_dll.so
    
2008/10/02@16:37:34.880390      3390    327700  PPP     WARNING 0x000008CA obpluginmanager.cpp:453 "Failed to load the plug-in"    function^ObPlugin::Load()       obstatus^60

2008/10/02@16:37:34.880549      3390    327700  CACHE   WARNING 0x00000502 ../obcacheof.cpp:860    "Unknown exception caught" function^ObCacheImpl::CallCreateElemFunc        obstatus^60     cacheName^ObPluginCache
    keyHashValue^228693822

2008/10/02@16:37:34.880816      3390    327700  PPP     WARNING 0x000008C9 obeventaction.cpp:359   "Failed to execute the plug-in" function^ObLibEventAction::Exec()  obstatus^60

2008/10/02@16:37:34.881652      3390    327700  APP_BASE        ERROR   0x000008BF module_main.cpp:831     "Could not complete the request successfully"   failedRequests^1
    
2008/10/02@16:37:34.881665      3390    327700  APP_BASE        ERROR   0x00000848  module_main.cpp:208     "OIS_LOG_PASSED_ERROR"  Error^../obport.cpp:818: Error: Unable to open the shared library /opt/oam/identity/oblix/unsupported/ppp/ppp_dll/libppp_dll.so -
    ../../../lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6).


Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms