Receiving Class File Has Wrong Version 49.0, Should Be 48.0 When Running App

(Doc ID 793127.1)

Last updated on NOVEMBER 01, 2016

Applies to:

Oracle Containers for J2EE - Version and later
Information in this document applies to any platform.
***Checked for relevance on 15-Feb-2012***


When trying to run a JSP page on the standalone OC4J server following error occurs:

"bad class file: x.class class file has wrong version 49.0, should be 48.0"

The OC4J server uses the jdk 1.4.2 as java runtime.


Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms