My Oracle Support Banner

Using The Java Plug-in (JRE/JPI) With Oracle Forms FAQ (Doc ID 794710.1)

Last updated on NOVEMBER 05, 2021

Applies to:

Oracle Forms - Version 10.1.2 to 11.1.2.1.0 [Release 10.1.2 to 11g]
Information in this document applies to any platform.
Checked for version accuracy : 07-Feb-2011


Purpose

The purpose of this document is to provide brief answers to some common questions related to the use of the Java Runtime Environment (JRE) / Java Plug-in (JPI) with Oracle Forms. If available, references to other documents, which contain details about the topic will be provided.

It is important to understand that this is not a "Java" document.  This document will only offer basic answers to common questions related to using the Java Plug-in with Oracle Forms.  If you have specific questions about the Java Plug-in or how to use or configure it, please refer to the Java Plug-in documentation.  Most of that documentation can be accessed from the Java SE pages.

Questions and Answers

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Purpose
Questions and Answers
 CLIENT SIDE CERTIFICATION AND SUPPORT
 Where can I find information about client side configurations which have been certified?
 What is the difference between the term "certified" and "supported"?
 Are products not listed in the Forms Client Statement of Direction supported?
 We currently use Oracle Jinitiator. Do we have to move to the JRE/JPI?
 Are additional releases of Java made available after a Java version reaches end-of-life for customers using dependent products, like Oracle Forms? 
 INSTALLATION
 How do I perform a silent installation?
 I have additional installation questions.  Is there a web page that contains more information about installation questions?
 CLIENT CONFIGURATION
 We upgraded to the JRE/JPI to 1.6.0_10 (or newer)*. Why do calls made to WEB.SHOW_DOCUMENT result in a browser window being sent behind the running form instead of to the foreground?
 How can we determine which JRE/JPI release has been installed?  For example,  32bit or 64bit.
 SERVER CONFIGURATION
 Are any server changes required in order to deploy my Forms application with the Sun JRE/JPI?
 How do I determine the correct CLSID for the JRE/JPI version I plan to use?
 How do I determine the correct value for jpi_codebase?
 Our client machines are not permitted to have Internet access. Can we host the JRE/JPI installation file within our Intranet?
 How do I determine which JDK is installed on the server or in the Oracle home?
 WORKING WITH SUPPORT TO ADDRESS JRE/JPI ISSUES
 What should I do if I believe that I have exposed a problem with the JRE/JPI while running Oracle Forms?
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.