Failed Data Source within a Multi Data Source doesn't reconnect (Doc ID 826905.1)

Last updated on JUNE 18, 2009

Applies to:

Oracle Weblogic Server - Version: 9.2 to 10.3
This problem can occur on any platform.

Symptoms

Multi data source has two data sources connecting to two databases (one to Oracle 10g & other to Oracle 9i) as its pool members.

While one of the databases is shutdown, the data source connecting to that DB is going to SUSPENDED mode (this is expected behavior).

But when the database is restarted, the data source which went into suspended mode (at the time of shutdown) is not reconnecting to the database. Its still in suspended mode and had to be started manually.

This behavior is not observed when both the databases are shutdown at the same time (to which multi data source pool member data sources connect) and restarted.

When both the databases are shutdown, both the data sources part of multi data source goto SUSPENDED mode (expected behavior). When the databases are brought back up both the data source reconnect and come to RUNNING state (expected behavior).
Only when one of the databases is shutdown, data source is not reconnecting after the database is restarted.

Changes

This behavior is not seen when both the databases are shutdown (to which multi data source pool member data sources connect) and restarted.

When both the databases are shutdown, both the data sources part of multi data source goto SUSPENDED mode (expected behavior). When the databases are brought back up both the data source reconnect and come to RUNNING state (expected behavior).
Only when one of the databases is shutdown, data source is not reconnecting after the database is restarted.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms