My Oracle Support Banner

Invoke WEB SERVICE Generated By WORKSHOP failed with java.lang.NoClassDefFoundError (Doc ID 827994.1)

Last updated on JULY 06, 2020

Applies to:

Oracle Workshop for Weblogic - Version 10.3 to 10.3 [Release AS10gR3]
Information in this document applies to any platform.
This problem can occur on any platform.

Symptoms

NOTE:  The attribute values used in this article represent fictitious sample names that made up as examples.  Any similarity to actual code, is purely coincidental and not intended in any other manner.

I use workshop to generate web service client to invoke the web service that develop in workshop and deployed to WebLogic Server. But I cannot invoke success, any if I invoke another web service which created use Oracle Web Service or Axis2, this will be OK.

Steps to Reproduce:

1. Create a Web Service Project in Workshop
2. Create a WebLogic Web Service, Simple create a hello world web service, or copy the source from
the HelloWorld sample in the WebLogic's sample fold.
3. Deploy the Web Service and test the web service in WebLogic, that's all OK.
4. Use "ClientGen Web Service Client" wizard to generate the Web Service Client.
5. Write the Client code to invoke the Web Service


7. I try to find the classpath, and make true that ServiceRefHandlerBean is in classpath, But run always with the exception.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.