Authentication Error occurred when upgrading from Oracle Weblogic Server 8.1sp2 to 8.1sp6. (Doc ID 832298.1)

Last updated on NOVEMBER 05, 2016

Applies to:

Oracle Weblogic Server - Version: 8.1
This problem can occur on any platform.

Symptoms

When trying to access the application we have a popup asking for login and password.
This popup didn't appear before, it's only happening since the upgrade from WLS 8.1SP2 to WLS8.1SP6.

Customer has a first application which authenticates against the LDAP and then passed this login information to the second application when customer accesses it.
In the second application, customer would not have to login again.
After upgrade to WLS V8.1 SP6, when customer access the second application, weblogic server pop up for login name and password.
In this pop up, it display weblogic as user. If customer remove this user and then use the user name of the first login and password,
it will not login successfully. If they use the weblogic as user and weblogic as password, it will login but it would not find weblogic as user at the backend in customer environment so customer would still not be able to access the second application.

On WLS V8.1 SP2, they did not see this behavior. It only happened after upgrading to WLS8.1SP6, they encountering this problem.






Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms