Unable to load mod_wl apache plug-in with error libstdc++.so.5: version `GLIBCPP_3.2' not found. (Doc ID 876694.1)

Last updated on OCTOBER 23, 2009

Applies to:

Oracle Weblogic Server - Version: 10.3
This problem can occur on any platform.
This problem may occur on all the OS platforms with all versions of plugin modules if required libraries are missing in OS level.
In this case Customer was using Oracle Enterprise Linux 5.2 64-bit OS, he was using 64-bit plugin module mod_wl_20.so for Apache 2.0.55.

Symptoms

User was getting below error when he did plug-in configuration in Apache 2.0.55. He was running Apache webserver on Oracle Enterprise Linux OEL 5.2 64-bit OS.
Error Message when starting apache server:
[oracle@lcrwbdl01v bin]$ ./apachectl -t
Syntax error on line 233 of /u01/app/apache/product/2.0.63/httpd-2.0/conf/httpd.conf:
Cannot load /u01/app/apache/product/2.0.63/httpd-2.0/modules/mod_wl_20.so into server:
/u01/app/apache/product/2.0.63/httpd-2.0/lib/libstdc++.so.5: version `GLIBCPP_3.2' not found
(required by /u01/app/apache/product/2.0.63/httpd-2.0/modules/mod_wl_20.so)


Changes

The user was setting up new environment with Apache plugin configuration.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms