Error "ORA-24777: Use Of Non-Migratable Database Link Not Allowed" Using Oracle XA Datasource When Executing a Select via Database Link. (Doc ID 879543.1)

Last updated on MAY 19, 2017

Applies to:

JDBC - Version 10.2.0.1 and later
Information in this document applies to any platform.
***Checked for relevance on 16-Jan-2014***


Symptoms

Websphere Portal Server using Oracle XA Datasource , JDBC Version 10.2.0.2.0, fails with the following error when executing a select via a database link against an Oracle 10.2.0.4 server:

java.sql.SQLException: ORA-24777: use of non-migratable database link not allowed
at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java(Compiled Code))
at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java(Inlined Compiled Code))
at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java(Compiled Code))
at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java(Compiled Code))
at oracle.jdbc.driver.T4CPreparedStatement.executeForDescribe(T4CPreparedStatement.java(Compiled Code))
at oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStatement.java(Compiled Code))
at oracle.jdbc.driver.T4CPreparedStatement.executeMaybeDescribe(T4CPreparedStatement.java(Compiled Code))
at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java(Compiled Code))
at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java(Compiled Code))
at oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:3422)


This issue can also occur with later JDBC versions and Oracle Server versions.


Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms