OSM 6.3.1 DESIGN STUDIO PLUG-IN DOES NOT WORK TOGETHER WITH ASAP STUDIO (Doc ID 1050370.1)

Last updated on AUGUST 13, 2013

Applies to:

Oracle Communications Order and Service Management - Version: 6.3.1 and later   [Release: 6.3 and later ]
Information in this document applies to any platform.
Checked for relevance on 28-Sep-2011

Symptoms


===================
-- Problem Statement:
The customer would like to configure Design Studio for UIM ,ASAP and OSM in one eclipse env. The issue is because OSM 6.3.1 (GA) Design studio Plugin "Studio-PROV-1.0.0-b276.tar" is based on "Studio-Core-2.1.0-b54.tar" for core plugin.

While UIM and ASAP plugins are based on Studio-CORE-2.2.0-b193.tar which is higher than OSM required version. We are not able to run all 3 plugins in one studio env. While UIM and ASAP supports same core version for plugin OSM 6.3.1 usage an older version which is not compatible.

-- Steps To Reproduce:
1.Install and configure OSM Design Studio as per setup guide.
2.Create an OSM project
3.Verify OSM Design Studio is working properly
4.Now install addditional Plugin for UIM and ASAP in same ecplise environment as OSM. Note: This will upgrade Studio Code Plugin.
5. varify ASAP and UIM feature of studio are working properly by creating some project for ASAP and UIM
6.Now OSM feature will not work and importing and existing project of OSM will through exceptions and hand studio GUI.

-- Business Impact:
The customers are not able to use ASAP and OSM project in single studio env and can not use Activation task feature of Studio while integrating OSM and ASAP

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms