THE TEMPLATE SEEMS TO BE IN EITHER CORRUPTED ONE OR NEWER VERSION THAN PDF1.4 (Doc ID 1075361.1)

Last updated on AUGUST 31, 2011

Applies to:

Oracle Clinical - Version: 4.6.0 and later   [Release: 4.6 and later ]
Information in this document applies to any platform.

Symptoms

New Patient Data Report fails with the following errors.

In log file:

LOG :
     Report: d:\opapps46\oc\RXCDMLPD.rep
     Logged onto server: OLSDEM2
     Username: OPS$DEMO3


1:==>   Graphic PDR ends with failure. error = 1007
1:==>   Graphic PDR ends with unexpected error. Please see the java log file for details: c:\temp\j4063.log
1:==> Report ending ...

In j.log:

Calling PDFBookBinder to bind files together
oracle.apps.xdo.template.pdf.exception.FatalException: The template seems to be in either corrupted one or newer version than PDF1.4
at oracle.apps.xdo.template.pdf.Xref.initialize(Unknown Source)
at oracle.apps.xdo.template.pdf.Xref.(Unknown Source)
at oracle.apps.xdo.template.pdf.PDFParser.initialize(Unknown Source)
at oracle.apps.xdo.template.pdf.PDFParser.(Unknown Source)
at oracle.apps.xdo.template.pdf.book.TOCProcessor.createPageCountMapping(Unknown Source)
at oracle.apps.xdo.template.pdf.book.TOCProcessor.process(Unknown Source)
at oracle.apps.xdo.template.pdf.book.PDFBookBinder.process(Unknown Source)
at oracle.pharma.rdc.pdr.PatientDataReport.bindPdf(PatientDataReport.java:1643)
at oracle.pharma.rdc.pdr.PatientDataReport.generateFull(PatientDataReport.java:1352)
at oracle.pharma.rdc.pdr.PatientDataReport.startPdr(PatientDataReport.java:1761)
at oracle.reports.engine.EngineImpl.CRunReport(Native Method)
at oracle.reports.engine.EngineImpl.run(EngineImpl.java:441)
at oracle.reports.engine._EngineClassImplBase._invoke(_EngineClassImplBase.java:90)
at com.sun.corba.se.internal.corba.ServerDelegate.dispatch(ServerDelegate.java:355)
at com.sun.corba.se.internal.iiop.ORB.process(ORB.java:280)
at com.sun.corba.se.internal.iiop.RequestProcessor.process(RequestProcessor.java:81)
at com.sun.corba.se.internal.orbutil.ThreadPool$PooledThread.run(ThreadPool.java:106)


Note error: The template seems to be in either corrupted one or newer version than PDF1.4


Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms