My Oracle Support Banner

Can ASAP 5.2.4 Run On JDK 1.4? (Doc ID 1263457.1)

Last updated on DECEMBER 04, 2019

Applies to:

Oracle Communications ASAP - Version 5.2.4 to 5.2.4 [Release 5.2]
Information in this document applies to any platform.

Goal

Can ASAP 5.2.4 run on JDK1.4?

We are seeing significant performance degradation on the server when using the pre-packaged JDK 1.5.

Supporting Information:
1.) Our installation came pre-packaged with JDK 1.5
2.) Version installed is: ASAP Release R5_2_4/b234/SunOS/Generic_141414-10/5.10/sun4v/Feb 26 2010 17:14:31

Performance Test Data supporting our observation:

1.) Same SQL Test using a java program was executed on similar hardware. One server running JDK1.4 and the other running JDK1.5

JDBCTest (SQL test)

JDK 1.4: 2274 ms
JDK 1.5: 3506 ms
Increase from 1.4 to 1.5: 54.1 %

2.) Same SQL Test using a java program was executed on similar hardware. One server running JDK1.4 and the other running JDK1.5. This time we switched JDBC Drivers too.

By changing the Java Version -
Driver Version: 9.2.0.8.0
JDK 1.4 (ms): 1987
JDK 1.5 (ms): 2274
By changing Java Version - % Increase: 14.44

Driver Version: 10.1.0.4.0
JDK 1.4 (ms): 2507
JDK 1.5 (ms): 3506
By changing Java Version - % Increase: 39.85

For the same Java Version but chaging JDBC Version
For JDK 1.4 - From Driver 9.2.0.8.0 to Driver 9.2.0.8.0 - % Increase: 26.17
For JDK 1.5 - From Driver 9.2.0.8.0 to Driver 9.2.0.8.0 - % Increase: 54.18

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.