OFSAA Patch Installation Fails with Syntax Error on ^M Control Characters (Doc ID 1272507.1)

Last updated on SEPTEMBER 17, 2015

Applies to:

Oracle Financial Services Funds Transfer Pricing - Version 5.1 and later
Oracle Financial Services Analytical Applications Infrastructure - Version 7.1 and later
Oracle Financial Services Profitability Management - Version 5.1 and later
Oracle Financial Services Asset Liability Management - Version 5.1 and later
Information in this document applies to any platform.
Oracle Financial Services Analytical Applications (OFSAA)

Symptoms

When installing Oracle Financial Services Analytical Applications (OFSAA) on the server, the install script fails with syntax errors.  This issue occurs for Infrastructure (OFSAAI), Profitability Management (OFSPM), Funds Transfer Pricing (FTP), and Asset Liability Management (ALM) patches.

For example, when applying OFSAAI Service Pack 1 7.1.1 (Patch 10243843), the following error occurs when running UpdateOFSAAI.sh:

$ ./UpdateOFSAAI.sh
: command not foundline 27:
: command not foundline 33:
'/UpdateOFSAAI.sh: line 34: syntax error near unexpected token `
'/UpdateOFSAAI.sh: line 34: `log_start()

When applying FTP Service Pack 5.1.1 (Patch 10258305), the following error occurs when running install.sh:

$ ./install.sh
: command not found21:
'/install.sh: line 23: syntax error near unexpected token `{
'/install.sh: line 23: `{

These errors prevent the patches from installing.

The following error may also appear on other OFSAA patches:

$ ./OFSAAIUpdate.sh
' unexpectedte.sh: line 12: syntax error at line 24: `do

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms