Receive the Error "This Class Does Not Support SAAJ 1.1" when Running a P6 Web Services Application

(Doc ID 1297252.1)

Last updated on NOVEMBER 21, 2016

Applies to:

Primavera Web Services - Version 8.0 and later
Information in this document applies to any platform.
***Checked for relevance on 01-April-2013***



  1. Receive the error "This class does not support SAAJ 1.1" or "Problems creating SAAJ model" when launching the Web Services demo
  2. Receive the following response message when calling a P6 Web Services service
    <soap:Envelope xmlns:soap=""><soap:Body><soap:Fault><faultcode>soap:Server</faultcode><faultstring>This class does not support SAAJ 1.1</faultstring></soap:Fault></soap:Body></soap:Envelope>


Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms