When Assigning Collection Agent To Bill Unit : Error Raised In Logs And No Notification Sent (Doc ID 1320754.1)

Last updated on OCTOBER 31, 2011

Applies to:

Oracle Communications Billing and Revenue Management - Version: 7.4.0.0.0 and later   [Release: 7.4.0 and later ]
Information in this document applies to any platform.

Symptoms


When one assign a bill unit to a collection agent, the assignment is done correctly however errors are raised in the logs (one for each action updated in the scenario) and no notification is sent (through event_notify)

1/ Put an account into collection (bill with overdue amount)
2/ Run the pin_collections_process batch => the account is in collection
3/ In the collection center (after configuring credentials with the
permissioning center + authorizations in customer center) : assign the bill
unit to an agent

The assignment is done but errors are raised (PIN_FLIST_FLD_GET errors on
PIN_FLD_ACTION_NAME) for each action


Snippet of the error


fm_collections_update_action result flist
# number of field entries allocated 20, used 2
0 PIN_FLD_POID POID [0] 0.0.0.1 /collections_action/manual_action 150389 2
0 PIN_FLD_AGENT_OBJ POID [0] 0.0.0.1 /account 154642 7
E Thu Feb 17 19:01:27 2011 XXXXX cm_batch_dbain:4505 pin_flist(69):2723 1:xx:UnknownProgramName:0:AWT-EventQueue-0:3841:1297965019:0
Bad flist ptr in pini_flist_get
E Thu Feb 17 19:01:27 2011 XXXXX cm_batch_dbain:4505 fm_collections_assign_agent.c:326 1:xx:UnknownProgramName:0:AWT-EventQueue-0:3841:1297965019:0
Update action error
<location=PIN_ERRLOC_FLIST:6 class=PIN_ERRCLASS_SYSTEM_DETERMINATE:1 errno=PIN_ERR_BAD_ARG:4>
<field num=PIN_FLD_ACTION_NAME:5,1852 recid=0 reserved=0 reserved2=0 time(sec:usec)=0:0>
<facility=0 msg_id=0 version=0>

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms