Libclntsh.so.11.1: Wrong ELF Class: ELFCLASS32 Error Starting OFSAA Messageserver (Doc ID 1329301.1)

Last updated on MARCH 09, 2017

Applies to:

Oracle Financial Services Analytical Applications Infrastructure - Version 7.2 and later
Information in this document applies to any platform.
Oracle Financial Services Analytical Applications (OFSAA)

Symptoms

After installing Oracle Financial Services Analytical Applications (OFSAA) 7.2 or higher, you get a shared library error when starting the messageserver:

./messageserver: error while loading shared libraries: libclntsh.so.11.1: wrong ELF class: ELFCLASS32

The error prevents the messageserver process from starting and prevents users from running OFSAA processes from the interface.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms