Missing Workflow Statuses When Creating Advanced Search On Workflow Status ($Currentstatus)

(Doc ID 1360779.1)

Last updated on AUGUST 21, 2016

Applies to:

Oracle Agile PLM Framework - Version 9.3.0.1 to 9.3.1.0 [Release 9.3.0.0 to 9.3.1.0]
Information in this document applies to any platform.

Symptoms

Find that the Status $CURRENTSTATUS and $STATUSTYPE.xxxx are disappearing and/or missing

EXPECTED BEHAVIOR
-----------------------
Expect that the status list show the available statuses

WHAT IS WORKING
---------------------------------
Re-starting the application server (OPMN) service and able to see all the statuses again, but the same problem starts over

STEPS
-----------------------
The issue can be reproduced at will with the following steps:

1. Open an Item (Part/Doc)
 
2. Select the Quality tab (or Changes tab)
 
3. Select Personalize (views) | Personalize
 
4. In the Table Personalization, select the Filter tab
 
5. Select Field: Status | In | Click on the Search to Add button
 
Note down the list of statuses to chose from
 
6. Close the Status pop-up box and close the Table Personalization window
 
7. Perform steps 3-6 again and note down the list of statuses. One is missing

8. Create an Advanced Search for an object that uses Workflow Status (Quality, Changes, etc)
Attribute Workflow Status | Equal To |

Note that there are missing $CURRENTSTATUS and $STATUSTYPE.xxxx

9. Perform steps 3-6 again and notice that each time a status disappears, until you get the following Warning:
 
There are no available values for this field. Please contact your Agile administrator
 
10. After this, trying to steps again, just causes the Search to Add button to just hang with Loading Data... but nothing is returned
 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms