My Oracle Support Banner

UpdateServiceOrderStatusFunctionsModule.xquery Doesn't Work With COM And SOM In Different Servers (Doc ID 1458880.1)

Last updated on MARCH 28, 2019

Applies to:

Oracle Communications Order and Service Management - Version 7.0.3 and later
Information in this document applies to any platform.

Symptoms

The UpdateServiceOrderStatusFunctionsModule.xquery library included in the OracleCgbuCommonDataDictionaryPIP productized cartridge doesn't work with OSM COM and SOM installed on different servers.

This behavior did not happen in the GA version of 7.0.3, it is now happening in the 20120219 build of the OSM PIP cartridges.

This library now imports the BillingInteractionModule.xquery and OSMEBMUtilityModule.xquery (and possibly other?) files that are included in the CommunicationsSalesOrderFulfillmentPIP cartridge that is not installed in the SOM server.

Consequently, an exception will always be thrown when a createUpdateProvisioningOrderPayload function (or any other function or constant) is imported from this library and  is invoked from a Provisioning cartridge.

This also affects the sample provisioning cartridges.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.