Java Version Validation Fails for OFSAAI 7.3 Install When Multiple Java Versions Exist (Doc ID 1461866.1)

Last updated on NOVEMBER 23, 2015

Applies to:

Oracle Financial Services Analytical Applications Infrastructure - Version 7.3 to 7.3 [Release 7]
Information in this document applies to any platform.
Oracle Financial Services Analytical Applications (OFSAA)

Symptoms

When installing Oracle Financial Services Analytical Applications (OFSAA) Infrastructure 7.3, the validation process called by validateXMLInputs.jar reports that the wrong Java version is installed.  However, the server has multiple Java versions installed, including the correct version for OFSAA 7.3.  The validation process is looking at the wrong Java version.

validateXMLInputs.jar uses the "which" Unix command to check the Java version. This command always selects the first Java version listed in the PATH environment variable.  So, if multiple Java versions are installed and a different version appears first in the PATH, it will trigger an error in the Validation process.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms