ATG SQL Repository API Causes Integrity Constraint Errors (ORA-02291 or ORA-02292) with Custom Tables

(Doc ID 1468232.1)

Last updated on MARCH 05, 2018

Applies to:

Oracle Commerce Merchandising - Version 2006.3 and later
Oracle Commerce Platform - Version 2006.3 and later
Information in this document applies to any platform.


This problem involves an integrity or foreign key constraint error on the database triggered by ATG SQL Repository code.  This could occur in a variety of circumstances, such as during item creation and content administration deployments or rollback deployments.  The exact error seen depends on the database being used.  Here are two Oracle database examples:



This is sometimes seen in during deployments after upgrading from ATG 2006.3 to a more recent version.


Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms