Unexepected 'IOS Version Mismatch' error on Cisco device (Doc ID 1491265.1)

Last updated on OCTOBER 24, 2016

Applies to:

Oracle Communications IP Service Activator - Version 5.2.4 and later
Information in this document applies to any platform.

Symptoms

The customer has an issue with one device in particular. The error message that is observed in the UI is as follows:

Configuration failed validation (Possible router upgrade. IPSA Device IOS Version does not match that of the Router - IPSA Device IOS Version: 15.1(3)S, RELEASE SOFTWARE (fc1)

This fault is generated by a pre-check in the cisco IOS cartridge which checks the IOS version on the device against the one in IPSA. If there is a mismatch then the fault will be raised. In this particular case there was no change to the IOS on the device, the problem seemed the just appear. However it is possible that although the IOS may have been upgraded at some earlier point, only after a discovery would this information proipogate into IPSA. The device and the service model and device model are both showing a consistently matched version with the device as shown below:

Service model

 

Changes

None recent although the IOS version on the device may have been upgraded at an earlier date, but not yet discovered into IPSA.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms