My Oracle Support Banner

Error: OFSAAI-1227 Cause Mismatch in Java versions Error Running Script While Installing OFSAAI 7.3 (Doc ID 1503441.1)

Last updated on NOVEMBER 03, 2017

Applies to:

Oracle Financial Services Analytical Applications Infrastructure - Version 7.3 and later
Information in this document applies to any platform.
Oracle Financial Services Analytical Applications Infrastructure (OFSAAI) - Version 7.3
Oracle Financial Services Analytical Applications (OFSAA) - Version 6.x


On OFSAAI 7.3 when attempting to run the Infrastructure installer for 7.3 the following error occurs:

./[63]: [: argument expected
Error: OFSAAI-1227

Check of all the Java setup appears to be the correct java version:

.profile entries:

export JAVA_HOME
export PATH

export JAVA_BIN

ofsaa@myserver:/opt/ofsaa/OFSAAI_INSTALLABLE/OFSAAI_73_LINUX_64bit $ java -version
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b04)
Java HotSpot(TM) 64-Bit Server VM (build 20.6-b01, mixed mode)
ofsaa@myserver:/opt/ofsaa/OFSAAI_INSTALLABLE/OFSAAI_73_LINUX_64bit $ which java

The issue can be reproduced at will with the following steps:
1. Update the OFSAAI_InstallConfig.xml with correct values.
2. Attempt to run the ./


To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!

In this Document

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.