Lib Errors While Installing Messaging Server (64bit) 7u4 On Linux 5.x (Doc ID 1510975.1)

Last updated on DECEMBER 23, 2016

Applies to:

Oracle Communications Messaging Server - Version 7.0.0 to 8.0.0 [Release 7.0.0 to 8.0.0]
Oracle Communications Convergence - Version 3.0.1 to 3.0.1 [Release 3.0]
Generic Linux

Symptoms

While attempting to install Comms Suite 7U2 -> MS 7u4 on Linux 5.x, we encountered the following lib errors:

root# uname -a
Linux hostname 2.6.18-194.17.4.0.1.el5 #1 SMP Tue Oct 26 20:10:33 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
root# cat /etc/*release
Enterprise Linux Enterprise Linux Server release 5.5 (Carthage)
Red Hat Enterprise Linux Server release 5.5 (Tikanga)
root# cd /san/mail/tmp
root# ls
V28359-01.zip
root# unzip -q V28359-01.zip
root# ./commpkg install
-- LOGFILE: /tmp/CommsInstaller_20121204141518.log
CommsInstaller version R7u2 (7.2-0.36 [7.0.2.0.0]) built on Fri Sep  9 13:45:17 PDT 2011

Welcome to the Oracle Communications Unified Communications Suite Product Installer
This program will install selected components of the Communications Suite
on your computer. Do note that the installer lays down the
bits, but does not do configuration. Separate configuration
steps for each individual product will be required.

Copyright 2011 Oracle Corporation. All rights reserved.
Use is subject to license terms.

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Specify Install Location

This program will extract the server files and install them
into a directory you specify. That directory is called the
INSTALLROOT in the product documentation and will contain
the server programs.

To accept the default shown in brackets, press the Enter key.


Install location [/opt/sun/comms]: /san/mail/ms
-- Creating /san/mail/ms
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Detecting Installed Products...
Detecting Installed Patches...
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Product Selection:

Shared Components (not shown) will be installed as required.
  you will be prompted later if Shared Components need to be upgraded.
OS patches (not shown) will be installed as required.

Communication Products:

    Item  Description
    ----  -----------
       1  Messaging Server (32bit) 7u4 (7.4-23.01)
       2  Messaging Server (64bit) 7u4 (7.4-23.01)
       3  Comms DSsetup 6.4 (6.4-23.01)
       4  Calendar Server 7u2 (7.2-4.19)
       5  Instant Messaging 9 (9.0-00.15)
       6  Convergence 2 (2.0-2.01)
       7  Indexing and Search Service 1u3 (1.3-8.6501)
       8  Comms Delegated Administrator 7 (7.0-4.00)


Enter the items you wish to install. Enter q to quit.
Prefix an item with ~ to indicate you only want
  to install shared component dependencies of that product
You can enter multiple items using commas to separate them.
For example: 1,2

Please select the products you wish to install [1, 2, 3, 4, 5, 6, 7, 8]: 2
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Generating list of things to install...
Checking for Shared Component Upgrade Requirements...
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
  WILL INSTALL: Simple Authentication and Security Layer 2.19
  WILL INSTALL: LDAPCSDK6 Tools 6.0
  WILL INSTALL: International Components for Unicode ICU2,ICU3
  WILL INSTALL: NSS/NSPR/JSS 4.8.8
  WILL INSTALL: LDAPCSDK6 6.0
  WILL INSTALL: Service Tags 1.1.4
  WILL INSTALL: JDK 1.6.0
  WILL INSTALL: Java Help Runtime 2.0
  WILL INSTALL: Message Queue 4.4
  WILL INSTALL: Message Queue Localization 4.4
  WILL INSTALL: Messaging Server (64bit) 7u4 (7.4-23.01)
  WILL INSTALL: CommsInstaller 7u2 (7.2-0.36)
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Ready to install

Do you want to continue ? [yes] : yes

==========================================================
Installing Simple Authentication and Security Layer 2.19...
------ Executing Task 1 of 34 ...
------ Executing Task 2 of 34 ...

==========================================================
Installing LDAPCSDK6 Tools 6.0...
------ Executing Task 3 of 34 ...

==========================================================
Installing International Components for Unicode ICU2,ICU3...
------ Executing Task 4 of 34 ...
------ Executing Task 5 of 34 ...
ERROR: rpm -i  /san/mail/tmp/Linux_x86/ICU/Packages/sun-icu-3.2.1-5.i386.rpm returned status 1
-- Start of command output--
error: Failed dependencies:
    libc.so.6 is needed by sun-icu-3.2.1-5.i386
    libc.so.6(GLIBC_2.0) is needed by sun-icu-3.2.1-5.i386
    libc.so.6(GLIBC_2.1) is needed by sun-icu-3.2.1-5.i386
    libc.so.6(GLIBC_2.1.3) is needed by sun-icu-3.2.1-5.i386
    libm.so.6 is needed by sun-icu-3.2.1-5.i386
    libm.so.6(GLIBC_2.0) is needed by sun-icu-3.2.1-5.i386
    libpthread.so.0 is needed by sun-icu-3.2.1-5.i386
    libpthread.so.0(GLIBC_2.0) is needed by sun-icu-3.2.1-5.i386
    libstdc++-libc6.2-2.so.3 is needed by sun-icu-3.2.1-5.i386
-- End of command output--

==========================================================
Installing NSS/NSPR/JSS 4.8.8...
------ Executing Task 6 of 34 ...
------ Executing Task 7 of 34 ...
ERROR: rpm -i  /san/mail/tmp/Linux_x86/NSS/Packages/sun-nspr-4.8.8-1.i386.rpm returned status 1
-- Start of command output--
error: Failed dependencies:
    libc.so.6 is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.0) is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.1) is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.1.2) is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.1.3) is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.2) is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.3) is needed by sun-nspr-4.8.8-1.i386
    libdl.so.2 is needed by sun-nspr-4.8.8-1.i386
    libdl.so.2(GLIBC_2.0) is needed by sun-nspr-4.8.8-1.i386
    libdl.so.2(GLIBC_2.1) is needed by sun-nspr-4.8.8-1.i386
    libpthread.so.0 is needed by sun-nspr-4.8.8-1.i386
    libpthread.so.0(GLIBC_2.0) is needed by sun-nspr-4.8.8-1.i386
    libpthread.so.0(GLIBC_2.1) is needed by sun-nspr-4.8.8-1.i386
    libpthread.so.0(GLIBC_2.2) is needed by sun-nspr-4.8.8-1.i386
    libpthread.so.0(GLIBC_2.3.2) is needed by sun-nspr-4.8.8-1.i386
-- End of command output--
------ Executing Task 8 of 34 ...
------ Executing Task 9 of 34 ...
ERROR: rpm -i  /san/mail/tmp/Linux_x86/NSS/Packages/sun-nss-3.12.10-1.i386.rpm returned status 1
-- Start of command output--
error: Failed dependencies:
    libc.so.6 is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.0) is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.1) is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.1.3) is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.2) is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.3) is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.3.2) is needed by sun-nss-3.12.10-1.i386
    libdl.so.2 is needed by sun-nss-3.12.10-1.i386
    libdl.so.2(GLIBC_2.0) is needed by sun-nss-3.12.10-1.i386
    libdl.so.2(GLIBC_2.1) is needed by sun-nss-3.12.10-1.i386
    libnspr4.so is needed by sun-nss-3.12.10-1.i386
    libplc4.so is needed by sun-nss-3.12.10-1.i386
    libplds4.so is needed by sun-nss-3.12.10-1.i386
    libpthread.so.0 is needed by sun-nss-3.12.10-1.i386
    libpthread.so.0(GLIBC_2.0) is needed by sun-nss-3.12.10-1.i386
    libpthread.so.0(GLIBC_2.1) is needed by sun-nss-3.12.10-1.i386
    libpthread.so.0(GLIBC_2.2) is needed by sun-nss-3.12.10-1.i386
    libz.so.1 is needed by sun-nss-3.12.10-1.i386
-- End of command output--
------ Executing Task 10 of 34 ...
------ Executing Task 11 of 34 ...
ERROR: rpm -i  /san/mail/tmp/Linux_x86/NSS/Packages/sun-jss-4.3.2-3.i386.rpm returned status 1
-- Start of command output--
error: Failed dependencies:
    libc.so.6 is needed by sun-jss-4.3.2-3.i386
    libc.so.6(GLIBC_2.0) is needed by sun-jss-4.3.2-3.i386
    libc.so.6(GLIBC_2.1.3) is needed by sun-jss-4.3.2-3.i386
    libdl.so.2 is needed by sun-jss-4.3.2-3.i386
    libnspr4.so is needed by sun-jss-4.3.2-3.i386
    libnss3.so is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.10.2) is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.12) is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.2) is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.3) is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.4) is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.6) is needed by sun-jss-4.3.2-3.i386
    libnssutil3.so is needed by sun-jss-4.3.2-3.i386
    libnssutil3.so(NSSUTIL_3.12) is needed by sun-jss-4.3.2-3.i386
    libplc4.so is needed by sun-jss-4.3.2-3.i386
    libplds4.so is needed by sun-jss-4.3.2-3.i386
    libpthread.so.0 is needed by sun-jss-4.3.2-3.i386
    libsmime3.so is needed by sun-jss-4.3.2-3.i386
    libsmime3.so(NSS_3.2) is needed by sun-jss-4.3.2-3.i386
    libsmime3.so(NSS_3.3) is needed by sun-jss-4.3.2-3.i386
    libssl3.so is needed by sun-jss-4.3.2-3.i386
    libssl3.so(NSS_3.2) is needed by sun-jss-4.3.2-3.i386
    libssl3.so(NSS_3.4) is needed by sun-jss-4.3.2-3.i386
-- End of command output--

==========================================================
Installing LDAPCSDK6 6.0...
------ Executing Task 12 of 34 ...
------ Executing Task 13 of 34 ...
------ Executing Task 14 of 34 ...

==========================================================
Installing Service Tags 1.1.4...
------ Executing Task 15 of 34 ...
ERROR: rpm -i  /san/mail/tmp/Linux_x86/ST/Packages/sun-servicetag-1.1.4-1.i386.rpm returned status 1
-- Start of command output--
error: Failed dependencies:
    libc.so.6 is needed by sun-servicetag-1.1.4-1.i386
    libc.so.6(GLIBC_2.0) is needed by sun-servicetag-1.1.4-1.i386
    libc.so.6(GLIBC_2.1) is needed by sun-servicetag-1.1.4-1.i386
    libc.so.6(GLIBC_2.3) is needed by sun-servicetag-1.1.4-1.i386
    libm.so.6 is needed by sun-servicetag-1.1.4-1.i386
    libpthread.so.0 is needed by sun-servicetag-1.1.4-1.i386
    libpthread.so.0(GLIBC_2.0) is needed by sun-servicetag-1.1.4-1.i386
    libuuid.so.1 is needed by sun-servicetag-1.1.4-1.i386
    libxml2.so.2 is needed by sun-servicetag-1.1.4-1.i386
    libz.so.1 is needed by sun-servicetag-1.1.4-1.i386
-- End of command output--

==========================================================
Installing JDK 1.6.0...
------ Executing Task 16 of 34 ...

==========================================================
Installing Java Help Runtime 2.0...
------ Executing Task 17 of 34 ...

==========================================================
Installing Message Queue 4.4...
------ Executing Task 18 of 34 ...
------ Executing Task 19 of 34 ...
------ Executing Task 20 of 34 ...
------ Executing Task 21 of 34 ...
------ Executing Task 22 of 34 ...
------ Executing Task 23 of 34 ...
------ Executing Task 24 of 34 ...
------ Executing Task 25 of 34 ...

==========================================================
Installing Message Queue Localization 4.4...
------ Executing Task 26 of 34 ...
------ Executing Task 27 of 34 ...
------ Executing Task 28 of 34 ...
------ Executing Task 29 of 34 ...
------ Executing Task 30 of 34 ...
------ Executing Task 31 of 34 ...
------ Executing Task 32 of 34 ...

==========================================================
Installing Messaging Server (64bit) 7u4 (7.4-23.01)...
------ Executing Task 33 of 34 ...

==========================================================
Installing CommsInstaller 7u2 (7.2-0.36)...
------ Executing Task 34 of 34 ...
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
SUMMARY:

FAILED: Task 5: rpm -i  /san/mail/tmp/Linux_x86/ICU/Packages/sun-icu-3.2.1-5.i386.rpm
        status 1
-- Start of command output--
error: Failed dependencies:
    libc.so.6 is needed by sun-icu-3.2.1-5.i386
    libc.so.6(GLIBC_2.0) is needed by sun-icu-3.2.1-5.i386
    libc.so.6(GLIBC_2.1) is needed by sun-icu-3.2.1-5.i386
    libc.so.6(GLIBC_2.1.3) is needed by sun-icu-3.2.1-5.i386
    libm.so.6 is needed by sun-icu-3.2.1-5.i386
    libm.so.6(GLIBC_2.0) is needed by sun-icu-3.2.1-5.i386
    libpthread.so.0 is needed by sun-icu-3.2.1-5.i386
    libpthread.so.0(GLIBC_2.0) is needed by sun-icu-3.2.1-5.i386
    libstdc++-libc6.2-2.so.3 is needed by sun-icu-3.2.1-5.i386
-- End of command output--
FAILED: Task 7: rpm -i  /san/mail/tmp/Linux_x86/NSS/Packages/sun-nspr-4.8.8-1.i386.rpm
        status 1
-- Start of command output--
error: Failed dependencies:
    libc.so.6 is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.0) is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.1) is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.1.2) is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.1.3) is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.2) is needed by sun-nspr-4.8.8-1.i386
    libc.so.6(GLIBC_2.3) is needed by sun-nspr-4.8.8-1.i386
    libdl.so.2 is needed by sun-nspr-4.8.8-1.i386
    libdl.so.2(GLIBC_2.0) is needed by sun-nspr-4.8.8-1.i386
    libdl.so.2(GLIBC_2.1) is needed by sun-nspr-4.8.8-1.i386
    libpthread.so.0 is needed by sun-nspr-4.8.8-1.i386
    libpthread.so.0(GLIBC_2.0) is needed by sun-nspr-4.8.8-1.i386
    libpthread.so.0(GLIBC_2.1) is needed by sun-nspr-4.8.8-1.i386
    libpthread.so.0(GLIBC_2.2) is needed by sun-nspr-4.8.8-1.i386
    libpthread.so.0(GLIBC_2.3.2) is needed by sun-nspr-4.8.8-1.i386
-- End of command output--
FAILED: Task 9: rpm -i  /san/mail/tmp/Linux_x86/NSS/Packages/sun-nss-3.12.10-1.i386.rpm
        status 1
-- Start of command output--
error: Failed dependencies:
    libc.so.6 is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.0) is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.1) is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.1.3) is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.2) is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.3) is needed by sun-nss-3.12.10-1.i386
    libc.so.6(GLIBC_2.3.2) is needed by sun-nss-3.12.10-1.i386
    libdl.so.2 is needed by sun-nss-3.12.10-1.i386
    libdl.so.2(GLIBC_2.0) is needed by sun-nss-3.12.10-1.i386
    libdl.so.2(GLIBC_2.1) is needed by sun-nss-3.12.10-1.i386
    libnspr4.so is needed by sun-nss-3.12.10-1.i386
    libplc4.so is needed by sun-nss-3.12.10-1.i386
    libplds4.so is needed by sun-nss-3.12.10-1.i386
    libpthread.so.0 is needed by sun-nss-3.12.10-1.i386
    libpthread.so.0(GLIBC_2.0) is needed by sun-nss-3.12.10-1.i386
    libpthread.so.0(GLIBC_2.1) is needed by sun-nss-3.12.10-1.i386
    libpthread.so.0(GLIBC_2.2) is needed by sun-nss-3.12.10-1.i386
    libz.so.1 is needed by sun-nss-3.12.10-1.i386
-- End of command output--
FAILED: Task 11: rpm -i  /san/mail/tmp/Linux_x86/NSS/Packages/sun-jss-4.3.2-3.i386.rpm
        status 1
-- Start of command output--
error: Failed dependencies:
    libc.so.6 is needed by sun-jss-4.3.2-3.i386
    libc.so.6(GLIBC_2.0) is needed by sun-jss-4.3.2-3.i386
    libc.so.6(GLIBC_2.1.3) is needed by sun-jss-4.3.2-3.i386
    libdl.so.2 is needed by sun-jss-4.3.2-3.i386
    libnspr4.so is needed by sun-jss-4.3.2-3.i386
    libnss3.so is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.10.2) is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.12) is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.2) is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.3) is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.4) is needed by sun-jss-4.3.2-3.i386
    libnss3.so(NSS_3.6) is needed by sun-jss-4.3.2-3.i386
    libnssutil3.so is needed by sun-jss-4.3.2-3.i386
    libnssutil3.so(NSSUTIL_3.12) is needed by sun-jss-4.3.2-3.i386
    libplc4.so is needed by sun-jss-4.3.2-3.i386
    libplds4.so is needed by sun-jss-4.3.2-3.i386
    libpthread.so.0 is needed by sun-jss-4.3.2-3.i386
    libsmime3.so is needed by sun-jss-4.3.2-3.i386
    libsmime3.so(NSS_3.2) is needed by sun-jss-4.3.2-3.i386
    libsmime3.so(NSS_3.3) is needed by sun-jss-4.3.2-3.i386
    libssl3.so is needed by sun-jss-4.3.2-3.i386
    libssl3.so(NSS_3.2) is needed by sun-jss-4.3.2-3.i386
    libssl3.so(NSS_3.4) is needed by sun-jss-4.3.2-3.i386
-- End of command output--
FAILED: Task 15: rpm -i  /san/mail/tmp/Linux_x86/ST/Packages/sun-servicetag-1.1.4-1.i386.rpm
        status 1
-- Start of command output--
error: Failed dependencies:
    libc.so.6 is needed by sun-servicetag-1.1.4-1.i386
    libc.so.6(GLIBC_2.0) is needed by sun-servicetag-1.1.4-1.i386
    libc.so.6(GLIBC_2.1) is needed by sun-servicetag-1.1.4-1.i386
    libc.so.6(GLIBC_2.3) is needed by sun-servicetag-1.1.4-1.i386
    libm.so.6 is needed by sun-servicetag-1.1.4-1.i386
    libpthread.so.0 is needed by sun-servicetag-1.1.4-1.i386
    libpthread.so.0(GLIBC_2.0) is needed by sun-servicetag-1.1.4-1.i386
    libuuid.so.1 is needed by sun-servicetag-1.1.4-1.i386
    libxml2.so.2 is needed by sun-servicetag-1.1.4-1.i386
    libz.so.1 is needed by sun-servicetag-1.1.4-1.i386
-- End of command output--

ERROR: 5 tasks failed
Checking JES java symlink...
INFO: /etc/softlist.xml updated

Hit Return to Continue:
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

NOTICE: To undo the installation, run the commands in:
        /var/opt/CommsInstaller/logs/undoCommsInstall_20121204141518

NOTICE: silent file created in:
        /var/opt/CommsInstaller/logs/silent_CommsInstaller_20121204141518
NOTICE: LOGFILE  created in:
        /var/opt/CommsInstaller/logs/CommsInstaller_20121204141518.log

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms