My Oracle Support Banner

OSM Out Of The Box O2A 7.2.0 Cartridge Certification In OSM 7.2.2.1 (Doc ID 1539526.1)

Last updated on JULY 16, 2020

Applies to:

Oracle Communications Order and Service Management - Version 7.2.2 and later
Information in this document applies to any platform.

Goal

We are upgrading OSM from 7.2.0 to 7.2.2.1

As per the documentation provided in OSM 7.2.2.1, we have tried below steps
1) Download latest version of OOTB O2A cartridge (7.2.0.4)
2) Run migrate.xml to migrate to 7.2.2.1
3) Deploy it in OSM 7.2.2.1

But OOTB O2A cartridge is not working in OSM 7.2.2.1 even after following all the steps ( SAF related errors, orders stuck at sync customer task) Environment is 3 Machines, 1 Admin and 2 Managed Servers, each in 1 machine (SAF and DQ)

When we directly deploy O2A 7.2.0 in 7.2.2.1, we get exceptions and orders will not work we found that this issue (7.2.0 deploying in 7.2.2.1) is because of a jar file osm-o2a-utility.jar, when we copied this jar from O2A 7.2.0.4 to O2A 7.2.0 and deployed, all the orders are working fine .

Would you please check whether will there be any issues with using O2A 7.2.0 after replacing the jar from 7.2.0.4. Also please provide compatibility certificate for the same

Current OSM version we are using is OSM 7.2.2.1.0.187
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.