UIM Response Is Not Reaching OSM Response Queue

(Doc ID 1618771.1)

Last updated on APRIL 04, 2014

Applies to:

Oracle Communications Order and Service Management - Version 7.2.2 and later
Information in this document applies to any platform.
This note is not suitable to KW, there are too many questions and no answers

Goal

Customer configured the OSM to UIM SAF Response JMS Queue in OSM. The automation Sender Plug-in is configured in such a way that local JNDI name is provided in To tab of Automation properties and Response Queue JNDI name is given under ReplyTo tab.Request sent by OSM is successfully reaching UIM but the UIM response is not coming in the response queue JNDI name provided. Customer is unable to find any error logs as well to debug the issue.

With a standalone Java code tested following scenarios:

1. Posted the message on OSM SAF queue (Request), which is then forwarded the message to UIM inventoryWSQueue
2. Posted the message on UIM SAF queue, which is then forwarded the message to OSM inventoryWSResponseQueue

This shows the configured SAF is working.
But now when posting a message on OSM SAF with ReplyTo JNDI value is same as Response Queue JNDI name, Customer is unable to get the response from UIM, this has been tested both from standalone Java code as well as OSM automation plug-in.
 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms