Issue While Installing Sensus RNI Adaptor 2.1.0.1 (Doc ID 1623680.1)

Last updated on FEBRUARY 07, 2017

Applies to:

Oracle Utilities Smart Grid Gateway Adapter for Sensus RNI - Version 2.1.0.1 and later
Information in this document applies to any platform.

Goal

While deploying the OSB Adapter for Sensus on a standalone weblogic instance, we are getting below error:
Buildfile: deploy-osb_D6.xml

deploy_osb:
  [echo] Performing All-in-One jar surgery

copy_to_config_dir:
  [copy] Copying 1 file to /u01/app/spl/MDMA2101/osbapp/osbconfig

jar_surgery_prepare:
  [delete] Deleting directory /u01/app/spl/MDMA2101/osbapp/osbconfig/tmp
  [mkdir] Created dir: /u01/app/spl/MDMA2101/osbapp/osbconfig/tmp
  [unjar] Expanding: /u01/app/spl/MDMA2101/osbapp/osbconfig/SGG-D6-ALL.jar into /u01/app/spl/MDMA2101/osbapp/osbconfig/tmp

jar_surgery_usage:

jar_surgery:
  [echo] Surgering '/u01/app/spl/MDMA2101/osbapp/osbconfig/tmp\SGG-D6-USAGE-CM' ...

jar_surgery_event:

jar_surgery:
  [echo] Surgering '/u01/app/spl/MDMA2101/osbapp/osbconfig/tmp\SGG-D6-EVENT-CM' ...

jar_surgery_finish:
  [jar] Building jar: /u01/app/spl/MDMA2101/osbapp/osbconfig/SGG-D6-ALL.jar
  [echo] Importing All-in-One into OSB
  [java]
  [java] Initializing WebLogic Scripting Tool (WLST) ...
  [java]
  [java] Welcome to WebLogic Server Administration Scripting Shell
  [java]
  [java] Type help() for help on available commands
  [java]
  [java] Problem invoking WLST - Traceback (innermost last):
  [java] File "/u01/app/spl/MDMA2101/osbapp/import_D6.py", line 6, in ?
  [java] ImportError: no module named wli
  [java]
  [java] Java Result: 1

BUILD SUCCESSFUL

Adding to above, sb-kernel-impl.jar and sb-kernel-api.jar are present under Oracle_OSB1/lib.
 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms