Java Plugin version 1.7.0_21 security requirements for applets in I-Learning (Doc ID 1641061.1)

Last updated on OCTOBER 13, 2015

Applies to:

Oracle iLearning - Version 6.0 and later
Information in this document applies to any platform.

Goal

Java Plug-in version 1.7.0_21 introduces the following security requirements for applets:

1. All applets must be signed

2. Permissions attributes must be specified in the .jar file manifest Since 1.7.0_51, live connect (applet communication with javascript) must use version u51.

Java does not support live connect in versions before u51. 

 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms