Is it ok to have multiple WLS Versions in one environment: 10.3.5 on OSB Server and 10.3.6 WLS For SGG Server (OUAF)? (Doc ID 1644350.1)

Last updated on AUGUST 22, 2014

Applies to:

Oracle Utilities Smart Grid Gateway Adapter for Itron OpenWay - Version 2.0.1.9 and later
Information in this document applies to any platform.

Goal

Customer has weblogic 10.3.6 on the OUAF server and weblogic 10.3.5 on their OSB server.
This scenario is using 2.0.0.9 SGG ItronOpenWay (2.1.0.9 MDM) and both WLS versions are supported for both weblogic and OSB server:

Documentation on supported versions from SGG Installation Guide 2.0.0.9.
Oracle WebLogic Web Server 11gR1 (10.3.5 or 10.3.6).

Oracle Service Bus 11.1.1.5.0 or 11.1.1.6.0
Oracle Service Bus is required for an implementation that plans to use a productized
adapter or the generic adapter to process meter reading or device event data.
Note:
Oracle Service Bus 11.1.1.5.0 requires Oracle WebLogic Server 10.3.5.
Oracle Service Bus 11.1.1.6.0 requires Oracle WebLogic Server 10.3.6.

We need to know if it is ok to be using both 10.3.5 and 10.3.6 in this environment instead of one or the other in both environments.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms