My Oracle Support Banner

Upgrade Errors From MS7u4 Patch 27 To MS 7u5 Patch 30 (Doc ID 1662892.1)

Last updated on SEPTEMBER 01, 2017

Applies to:

Oracle Communications Messaging Server - Version 7.0.0 and later
Information in this document applies to any platform.

Symptoms

We are seeing an issue with an upgrade from MS 7u4 patch 27 to MS 7u5 patch 30 using patchadd:

#  patchadd 137204-30

LOGFILE = /opt/sun/comms/messaging64/log/updateCfgVersion_20140410172941.log
ERROR: Command: /opt/sun/comms/messaging64/lib/inetuser check-dssetup --ssldbupgrade
  returned status 77
-- Start of command output--
inetuser: dssetup version information cannot be retrieved from the Directory Server. This is most likely due to the use of an old release of dssetup. Messaging Server requires dssetup version 6.4-5.05 or newer. Refer to https://xxxx.oracle.com/display/CommSuite7/Messaging+Server+7+Update+3+Release+Notes for further details.
-- End of command output--
ERROR: Failed validation checks
-- INFO: NUMERRS = 1, check log file /opt/sun/comms/messaging64/log/updateCfgVersion_20140410172941.log
/opt/sun/comms/messaging64/lib/updateCfgVersion failed with status 1

 

$ ldapsearch  -b o=comms-config objectclass=top
version: 1
dn: o=comms-config
objectClass: top
objectClass: organization
o: comms-config

dn: cn=CommServers,o=comms-config
objectClass: top
objectClass: sunCommsMetaData
sunkeyvalue: dssetup_ver=6.4
sunkeyvalue: dcsuffix=o=internet
sunkeyvalue: ugsuffix=o=email
sunkeyvalue: schematype=1
sunkeyvalue: dssetup_rev=5.05
cn: CommServers


Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.