Demantra 12.2.3 : Collaborator.log Updates Not Reflected On Admin Tools > System Logs URL And There Is a Time Lag (Doc ID 1904901.1)

Last updated on AUGUST 16, 2016

Applies to:

Oracle Demantra Demand Management - Version 12.2.3 and later
Information in this document applies to any platform.

Symptoms

Customer mentions that there is time lag in the collaborator logs between the logs in the server and ones viewed online through the admin page.
The difference in time can be from anything like 3 minutes to 4-5 hours. It is not consistent as to the time lag. Refreshing the screen (F5), bouncing application does not help

Customer is on 12.2.3 deployed on weblogic

VERSION BUILD SP UPGRADE_DATE
12.2.3 6 0 3/14/2014 11:33:57 AM

Their database server, web server and client machine are all on the same time zone

This happens using any browser (IE, Firefox, Chrome), and they all exhibit the exact same behavior.

Clearing java cache, browser cache does not help

Here are a few examples of the time lags

1. Time lag of 1 hours 20 minutes

The collaborator.log on server
2014-04-02 13:15:47,443 CDT [ DEBUG actions.sql: 'appserver.actions.sql' is Off

On the web
2014-04-02 11:55:25,936 CDT [ DEBUG actions.sql: 'appserver.actions.sql' is Off

2. Time lag of 30 minutes

The collaborator.log on server
2014-04-02 19:36:50,917 CDT Mail_Thread ERROR workflow.steps: MailThread:run()::No Sender or Reciever
2014-04-02 20:02:00,619 CDT [ DEBUG actions.sql: 'appserver.actions.sql' is On
2014-04-02 20:03:42,977 CDT [ DEBUG actions.sql: 'appserver.actions.sql' is Off


Log on the web

2014-04-02 19:36:50,917 CDT Mail_Thread ERROR workflow.steps: MailThread:run()::No Sender or Reciever

3. Time lag of almost 5 hours

Back-end logfile test case entry :
2014-04-07 09:52:59,314 CDT [ DEBUG actions.sql: 'appserver.actions.sql' is On
2014-04-07 09:53:00,205 CDT [ DEBUG advisor.index_prop: 'appserver.advisor.index_prop' is On
2014-04-07 09:53:01,248 CDT [ DEBUG advisor.index_prop: 'appserver.advisor.index_prop' is Off
2014-04-07 09:53:01,751 CDT [ DEBUG actions.sql: 'appserver.actions.sql' is Off


URL last entry :
2014-04-07 05:10:43,083 CDT Mail_Thread ERROR workflow.steps: MailThread:run()::No Sender or Reciever

4. Customer did a bounce and after a while the time lag starts and keeps increasing

Here is what the URL now shows CURRENT :
2014-04-07 12:20:53,282 CDT Mail_Thread ERROR workflow.steps: MailThread:run()::No Sender or Recieve

But, if they simply redo the test case again, it is NOT current, it is lagging behind :

Log :
2014-04-07 12:23:51,384 CDT [ DEBUG advisor.index_prop: 'appserver.advisor.index_prop' is Off
2014-04-07 12:23:51,798 CDT [ DEBUG actions.sql: 'appserver.actions.sql' is Off


URL :
2014-04-07 12:20:53,282 CDT Mail_Thread ERROR workflow.steps: MailThread:run()::No Sender or Recieve


They have ensured that they were looking into the same instance.  They now further add that they have installed a 2nd instance on separate hardware. The exact same issue persists there as well.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms