Get Attachment Function Of SDK Not Working After Installing Agile PLM Patch 9.3.3.0.30 (Doc ID 1909485.1)

Last updated on SEPTEMBER 01, 2017

Applies to:

Oracle Agile PLM Framework - Version 9.3.3.0 and later
Information in this document applies to any platform.

Symptoms

On Agile PLM 9.3.3.0 version, Software Development Kit

Get attachment function of SDK not working after installing Agile PLM patch 9.3.3.0.30

Get attachment from read-only vault was not working in Agile PLM 9.3.3 and it was advised to install Patch 9.3.3.0.61 .

Prerequisite HF for HF 9.3.3.0.61 was HF 9.3.3.0.30.
Prerequisite HF for HF 9.3.3.0.30 was HF 9.3.3.0.15, HF 9.3.3.0.3, HF 9.3.3.0.2

We installed the above mentioned 5 patches and the get attachment from read-only started working.
But during the testing...we found that Get attachment function via SDK ( process extension) stopped working.
On analysis..we found that after installing HF 9.3.3.0.30 ..the Get attachment function via SDK starting giving error.

We enabled debug mode in log.xml for <category name="com.agile.webfs" additivity="false">.
File manager started properly and clicking on integration (get function), error message is populated in Catalina.out file...pls. find attached the same.
 

ERROR
java.lang.RuntimeException at com.agile.api.pc.attachment.IFSInputStream.(IFSInputStream.java:40)


STEPS
The issue can be reproduced at will with the following steps:
1. Create a sample code to download a file with SDK
2. Run the code and observe the error output
  java.lang.RuntimeException at com.agile.api.pc.attachment.IFSInputStream.(IFSInputStream.java:40)

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms