OSM Patch Upgrade failed using Silent Installation (Doc ID 1916388.1)

Last updated on MARCH 01, 2017

Applies to:

Oracle Communications Order and Service Management - Version 7.0.3 and later
Information in this document applies to any platform.

Goal

While trying to upgrade the server from one version to other in OSM 7.0.3 using silent installation, getting following exception in the logs

10-Aug-2014 00:45:18), Setup.product.install, com.mslv.oms.installation.OMSInstallAction, err, java.lang.Exception: No bundle-version found for the CMWS ear file.
STACK_TRACE: 6
java.lang.Exception: No bundle-version found for the CMWS ear file.
at com.mslv.oms.installation.util.VersionManager.getVersionForCurrentCMWS(VersionManager.java:93)
at com.mslv.oms.installation.OMSInstallAction.weblogicVersionCheck(OMSInstallAction.java:845)
at com.mslv.oms.installation.OMSInstallAction.execute(OMSInstallAction.java:246)
at com.installshield.wizard.RunnableWizardBeanContext.run(Unknown Source)


BUILD FAILED
/wls_domains/dypalbtw01/OSM_Patch26/Database/dbinstall/install/instplb.xml:47: com.mslv.install.db.util.DbManagerException: Cannot validate configuration file.

Total time: 3 seconds
(10-Aug-2014 00:45:38), Setup.product.install, com.mslv.oms.installation.AntExecAction, err, /wls_domains/dypalbtw01/OSM_Patch26/Database/dbinstall/install/instplb.xml:47: com.mslv.install.db.util.DbManagerException: Cannot validate configuration file.
STACK_TRACE: 37
/wls_domains/dypalbtw01/OSM_Patch26/Database/dbinstall/install/instplb.xml:47: com.mslv.install.db.util.DbManagerException: Cannot validate configuration file.
at com.mslv.install.db.ImportDBTask.execute(ImportDBTask.java:46)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
at org.apache.tools.ant.Task.perform(Task.java:364)
at org.apache.tools.ant.Target.execute(Target.java:341)
at org.apache.tools.ant.Target.performTasks(Target.java:369)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
at com.mslv.oms.installation.AntExecAction.run(AntExecAction.java:297)
at java.lang.Thread.run(Thread.java:637)
Caused by: com.mslv.install.db.util.DbManagerException: Cannot validate configuration file.
at com.mslv.install.db.application.definition.ApplicationConfig.getAppConfig(ApplicationConfig.java:141)
at com.mslv.install.db.application.definition.ApplicationConfig.(ApplicationConfig.java:58)
at com.mslv.install.db.processor.ProcessorHelper.prepareApplicationModelFromJar(ProcessorHelper.java:35)
at com.mslv.install.db.processor.ApplicationProcessor.importApplicationModel(ApplicationProcessor.java:104)
at com.mslv.install.db.ImportDBTask.execute(ImportDBTask.java:39)
... 10 more

 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms