3.1.2 to 11.0.0 Migration Script Produces Invalid XML for PageSlot and Causes "Invalid Content item XML" in Experience Manager (Doc ID 1933808.1)

Last updated on DECEMBER 22, 2016

Applies to:

Oracle Commerce Guided Search / Oracle Commerce Experience Manager - Version 11.0 and later
Information in this document applies to any platform.

Symptoms

In Experience Manager, the user tries to open a page that was migrated from an earlier version, such as 3.1.2.  When the user clicks on the page in the left-hand navigation pane, a popup window appears with the error: "Invalid Content item XML could not be loaded" .

The page uses a content item such as a PageSlot.  Creating a new PageSlot does not give this error.


The issue has the following business impact:
Due to this issue, users cannot use existing cartridge templates in their new 11 environment.  Creating a new PageSlot works fine.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms