Database Upgrade From ETPM 2.3.1 (SP2) To PSRM 2.4.0(SP1) is Failing

(Doc ID 1940667.1)

Last updated on APRIL 16, 2015

Applies to:

Oracle Public Sector Revenue Management - Version 2.3.1.1.0 and later
Information in this document applies to any platform.

Symptoms

Upgrading the ETPM 2.3.1 SP2 database to PSRM 2.4.0 SP1 directly, the framework patches work fine. Upon trying to apply the ETM patches, an error is raised.                                      However upgrading the database from ETPM 2.3.1 SP2 to PSRM 2.4.0 and then applying the PSRM SP1 patch to bring the database to PSRM 2.4.0.1 (PSRM SP1) level works fine.

ERROR
-----------------------
Insert into SC_ACCESS_CNTL (USR_GRP_ID,APP_SVC_ID,ACCESS_MODE,VERSION,OWNER_FLG) values ('ALL_SERVICES ','C1360ACTADDRS ','R ',1,'CM ')
/
ERROR: ORA-00001: unique constraint (CISADM.SYS_C0041614) violated (DBD ERROR: OCIStmtExecute) occured while executing Insert into SC_ACCESS_CNTL (USR_GRP_ID,APP_SVC_ID,ACCESS_MODE,VERSION,OWNER_FLG) values ('ALL_SERVICES ','C1360ACTADDRS ','R ',1,'CM ')

STEPS
1. Upgrade the ETPM 2.3.1 SP2 database to PSRM 2.4.0 SP1 directly 

2. Apply the ETM patches, an error is raised

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms