Database Upgrade From 5.1.x to 6.0 Failed With the Error "SQL execution error, ORA-03114: Not connected to Oracle" (Doc ID 1943917.1)

Last updated on NOVEMBER 11, 2014

Applies to:

Oracle Argus Safety - Version 7.0.4 and later
Information in this document applies to any platform.

Symptoms

Getting the following error when upgrading database from 5.1.3.7 to 6.0:

"Password encryption error. Unable to convert passwords to new encryption. SQL Execution Error: ORA-03114: Not Connected to Oracle."

Steps to Repeat:
1. Setup Argus 5.1.3.7 database
2. Upgrade the database from 5.1.3.7 to 6.0
3. Upgrade process executes all SQL scripts successfully
4. At the end of upgrade execution it is trying to create another connection to encrypt password which failed with following message

Password encryprtion error:
Unable to convert passwords to new encryption.
SQL execution error, ORA-03114: Not connected to Oracle.

Note: This upgraded executed 4 times successfully. The only difference is another environment in a different network

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms