Web Client Does Not Automatically Add $approver Variable On The Workflow (Doc ID 1945762.1)

Last updated on JANUARY 19, 2016

Applies to:

Oracle Agile Product Collaboration - Version 9.3.2.0 and later
Information in this document applies to any platform.

Symptoms

On : 9.3.2.0 version, Web Client does not automatically add $approver variable on the workflow

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1, Setup a workflow that has the following steps example below:
Pending --> Submit ---> Approve 1 --> Approve 2 --> Release 1 -- Release 2
2, Now assign default approver on Release 1 status to be $Approver
3, Create an ECO, move status from Pending to Submit, then to Approve1 status, and add a user to Approver 1 as an approver
4, Promote the ECO to Approve 2, will get message like "Not all approvers responded.", just ignore the warning and skip, will pop-up the add approver window for Approve2 status, it show blank on Approver, do not add any approvers
5, Promote the ECO to Release 1,the problem is the user does not appear and it remains as empty approver. ( expect to see the user assigned at Approve 1 to be also an approver on Release 1)

BUSINESS IMPACT
-----------------------
Missing key approvers from the process

Changes

 No

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms