Inconsistent Data Model Upload Errors With Same Erwin Data Model (Doc ID 1987461.1)

Last updated on AUGUST 07, 2017

Applies to:

Oracle Financial Services Analytical Applications Infrastructure - Version 7.3.3.0.0 and later
Information in this document applies to any platform.
Oracle Financial Services Analytical Applications Infrastructure (OFSAAI)
Oracle Financial Services Analytical Applications (OFSAA)

Goal

Have been doing a data model upload work to minimize the time spent and predict what types of issues we will encounter when uploading the same. The objective is to be prepared, run all the pre-requisite scripts such as :
truncate tables, convert views to tables, drop pk/fk, etc.  However, the model upload logs fail with different errors using the same model file.

EXPECTED BEHAVIOR
Expect to see the exact same model upload on every single load of the same .xml data model file. 

Model upload is executed from upload.sh.

The issue can be reproduced at will by the customer with the following steps:
1. Got a full export from PROD with the ATOMIC and CONFIG schemas
   a.  Compared the test vs production schema after import - No differences
2. Got a full backup of the FTPSHARE location
3. Run the data model upload
4. Run about 25 times in one day, gathered all the necessary changes to be made prior to the re-upload. Repeate the process above again, and next time we got thru around 10 times and we got new results. Repeated the process one
more time and again found different tables to be modified (truncated) that were not present on the first and second round.

Why do the model upload logs look different with the same data model and files?

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms